Faq

How can you transfer Oracle 11g or 12c to a new server with Oracle 12c?

To transfer an Oracle 11g or 12c database to a new server with an Oracle 12c database, use the ORACLE database export and import tools.

To export the database:

1. After starting the sql client, e.g .:

  • <CMD> sqlplus /nolog
  • <SQL> connect system/pass as sysdba;

2. Create a new directory in the Oracle database to which the export will be performed and grant it the required permissions

  • <SQL> CREATE DIRECTORY asistdmpdir AS ‘C:\asistdmpdir’;
  • grant read,write on directory asistdmpdir to asist5;

3. Check if the directory for the ORA engine has been created correctly:

  • <SQL> SELECT directory_name, directory_path FROM dba_directories;

4. Perform database export:

  • expdp asist5/hasło_użytkownika DIRECTORY=asistdmpdir DUMPFILE=asist.dmp  LOGFILE=asist_export.log

To import the database:

1. Create a new PDB database, to which the schema will be imported:

  • SQL> create pluggable database asistpdb admin user asistdba identified by asist file_name_convert=(‘ D:\app\oracle\oradata\orcl\pdbseed’,’D:\app\oracle\oradata\orcl\asistpdb’);
  • SQL> alter pluggable database asistpdb open read write;
  • alter session set container=asistpdb;
  • alter pluggable database asistpdb save state instances=all;

2. Create a new directory for import and grant it the required permissions:

  • CREATE DIRECTORY asistdmpdir AS ‘C:\asistdmpdir’; 
  • grant read,write on directory asistdmpdir to system;

3. Create a user and tablespace:

  • SQL> create tablespace users datafile ‘D:\app\oracle\oradata\orcl\asistpdb/asist01.dbf’ size 1G autoextend on;
  • SQL> create user asist5 identified by asist5 default tablespace users;
  • SQL> grant connect, resource, create any view, unlimited tablespace to asist5;

4. In the tnsnames.ora file, add an entry about the plug-in database:

ASISTPDB =

  (DESCRIPTION =

    (ADDRESS_LIST =

      (ADDRESS = (PROTOCOL = TCP)(HOST = serwer)(PORT = 1521))

    )

    (CONNECT_DATA =

      (SERVICE_NAME = asistpdb)

    )

  )

An example file location is: D:\app\oracle\product\12.2.0\dbhome_1\network\admin

5. Perform an import from the system user:

  • impdp system/system@asistpdb directory=asistdmpdir logfile=imp.log dumpfile=asist.dmp

Additional parameters for the import command:

remap_schema – to use when changing the target schema, syntax: oldUser:newUser np. remap_schema=asist5:asis

remap_tablespace – to use when changing target user space, syntax: oldTablespace_newTablespace np. remap_tablespace=users:asistdata

Link to a helpful article (import syntax a bit simpler):

http://orafaq.com/wiki/Datapump

For the aSISt application to connect to the new Oracle database, change the database address in the db.properties file by entering:
  • db.url=jdbc\:oracle\:thin\:@serwer\:1521/asistpdb
How can I back up / restore the Oracle Database 12c?

To perform and restore a backup of Oracle Database 12c, use the export and import functions described in point 5 on this page.

How can I back up / restore the Oracle Database 11g Express Edition?

The Oracle database shortcut folder has two options for backing up and restoring the database, for example:

• backup script:

“Start Menu” -> “Programs” -> “Oracle Database 10g Express Edition” -> “Backup Database”

• script to restore the LAST backup version:

“Start Menu” -> “Programs” -> “Oracle Database 10g Express Edition” -> “Restore Database”

By default, the Oracle Database 11g Express Edition works in NOARCHIVELOG mode, which does not allow restoring data together with database transactions that took place between subsequent archives.

The “Backup Database” script running for Oracle working in the default NOARCHIVELOG mode returns a warning about this option. Giving consent to make a backup in this mode results in creating (after automatically stopping and restarting the database via the script) a copy of the data without the possibility of restoring the above transaction.

Switching the database in ARCHIVELOG mode causes that the database creation process is performed in the background and archiving restore logs are performed in the so-called required FRA restore (FLASH RECOVERY AREA).

In this mode, the database allows you to make backups without having to stop the database engine, but the consumption of the FRA area increases significantly. In this case, the creators of the Oracle database recommend moving the area in question to a separate partition, setting its size to at least 15 GB and regularly performing “backups” to prevent overflowing of this area and loss of log data.

The transaction recovery log archive mode avoids data loss, also as a result of critical media errors, the default NOARCHIVELOG option is sufficient to provide protection against operating system errors and errors of the database instance itself.

More information on the above issues can be found in the official online documentation of the ORACLE XE database:

http://download.oracle.com/docs/cd/B25329_01/doc/admin.102/b25107/toc.htm

If you need to create and restore copies of Oracle databases with user-defined settings, Oracle distributions also include a standard copy management tool, available from the installation directory:

– subdirectory „oraclexeapporacleproduct10.2.0serverBIN” -> „rman.exe”

– example command „rman nocatalog target XE” allows you to connect the tool to a database instance called XE (after entering the SYS user password) to make a copy

– rman command:

backup full database format „d:/backup/rman_%T_%s_%p.bus”;

allows you to create a full copy of the database in the target directory d:/backup.

Note: if the database does not work in ARCHIVELOG mode, it must be manually stopped and “mounted” via the command string of the rman program or SQL interpreter:

shutdown immediate
startup mount

After successful backup, the SQL command “alter database open;” allows you to restart the base engine.

• The basic process of restoring the last copy of the database using the rman program is limited to issuing the command string:

rman nocatalog target XE (next the SYS user password)
shutdown immediate
startup mount
restore database;
recover database;
alter database open;
exit

Rman command “restore database;” restores the last database archive existing in the current control file (command ‘list backup;’ – displays the content of the control file)

the recover command allows you to check the consistency of the database.

After completing the restoration process and starting the database, it is again recommended to check if all necessary system spaces (tablespaces) and data files are online:

SQL > select TABLESPACE_NAME,STATUS from dba_tablespaces; SQL> select FILE#,STATUS,ENABLED,NAME from v$datafile;

Operations related to extracting control files from total copies, restoring specific arrays or so-called backup sets are more complicated issues, the description of which can be found in the source Oracle database documentation.

Will the aSISt application work with the free Oracle version and where can I find it?

There are no contraindications for the aSISt application to work with the free version of the Oracle database.

The free available version is: Oracle Database Express Edition (XE) Release 11.2.0.2.0 (11gR2).

Link to Oracle website:

https://www.oracle.com/technetwork/database/database-technologies/express-edition/downloads/xe-prior-releases-5172097.html

Link to documentation on the Oracle website:

https://docs.oracle.com/cd/E17781_01/install.112/e18803/toc.htm

How can I transfer an Oracle 11g database to a new server with Oracle 18 XE?

To stay on the free version of the Oracle database, we suggest migrating to the Oracle 18 XE (Express Edition) database, available for download on the official Oracle database website.

for Windows x64 and Linux x64: https://www.oracle.com/database/technologies/xe-downloads.html

The difference between Oracle 18 XE (Express Edition) and 11 XE (Express Edition) is as follows:

  • increasing the storage space for user data from 11GB to 12GB
  • increasing the maximum RAM consumption per database instance from a maximum of 1GB RAM to 2GB RAM
  • increasing the CPU for query processing within the database engine from 1 CORE OF CPU to 2 CORES OF CPU
  • creating and managing a plug-in database (pluggable database) in the database installation in the default CDB (container database) mode for the needs of aSISt, preparation of the database schema for the aSISt application is presented in the document describing the installation of the aSISt application in the Oracle section on 12c in the default installation mode CDB (container database)
  • the free Oracle 18 XE database provides the ability to create up to 3 plug-in databases

The transfer of the Oracle database to the server with the Oracle 18 XE (Express Edition) database is performed in the same way as described in point: “How can I transfer an Oracle 11g or 12c database to a new server with an Oracle 12c database?” in the FAQ on this aSISt website.

We would like to add that we do not provide Oracle database installation instructions.

All materials on the installation, configuration and administration of the database in its various versions can be found on the official website of the database producer.

On the Windows Server operating system, before installing the database, you need to create the user of the operating system on which the Oracle services will run (database service, listener, job scheduler, etc.), to then indicate it in one of the installation stages.

On Linux, in addition to creating appropriate user groups along with the above-mentioned service user and assigning him to appropriate groups, you also need to make the required changes to the kernel settings or security limits for users, set environment variables, create a folder for the ORACLE_HOME location, etc. according to official Oracle documentation.

When installing the database, follow the wizard.

Database encoding should be selected according to the aSISt application installation manual, according to the current database encoding.

Otherwise, the default encoding will be set and you should verify it after installation. Description of this function is available under “How to check what encoding is used by the installed Oracle database?” of this FAQ.

The default 18XE base encoding is AL32UTF8.

If the currently set encoding of the base (from which the migration will take place) is different, but also supported by the aSISt application (see aSISta installation documentation  https://support.asist-xbrl.eu/sites/default/files/asist/Distributions/5.39.2.0/aSISt-%20opis%20instalacji%205.39.2.0.pdf )  and you plan to stay on it, avoiding possible data conversion from one encoding to another, run the Oracle XE installer with the parameter indicating the current encoding, i.e .:

setup.exe /v”CHAR_SET=<character_set>”

for example:

setup.exe /v”CHAR_SET=EE8MSWIN1250″

After installation, you need to verify the encoding:

select * from NLS_DATABASE_PARAMETERS where parameter=’NLS_CHARACTERSET’

How can you transfer Oracle 11g to a new server with Oracle 11g?

To transfer the Oracle 11g database to a new server with the Oracle 11g database, use the ORACLE database export and import tools.

To export the database:

1. After starting the sql client, e.g .:

  • sqlplus / nolog
  • connect userid = system / pass as sysdba;

check the directories created for the ORA engine to which the database can save files in the operating system:

<SQL> SELECT directory_name,directory_path FROM dba_directories; (by default, the backup will be performed to the directory pointed to by “DATA_PUMP_DIR”)

2. To export the database, create a new directory to save the database dump or use the existing DATA_PUMP_DIR:

  • creating a new directory in the Oracle database to which export will be made:

<SQL>CREATE DIRECTORY asistbackup AS ‚C:\oracle_backup’;

<SQL>grant read,write on directory asistbackup to asist5;

  • database export from the Windows command line:

<CMD>expdp asist5/pass DIRECTORY=asistbackup DUMPFILE=asist.dmp  LOGFILE=asist_export.log

The data of the exported user should be saved in the required directory (here, for example, asistbackup).

To import the database:

1. For the new base:

– check the ORA engine catalogs and their paths,

– create the desired DIR.

2. Import the file exported using the previous export procedure.

The file to be imported should be placed in the appropriate directory indicated by DATA_PUMP_DIR or in the newly created folder:

  • creating a new directory in the Oracle database to be imported:

<SQL> CREATE DIRECTORY asistbackup AS ‚C:\oracle_backup’;

  • database import from the Windows command line:

<CMD> impdp system/pass DIRECTORY=asistbackup logfile=import.log dumpfile=asist.dmp

By default, the schema will be imported under the same name as in the source database, if you want to change it, you can use the additional switches:

remap_schema – is equivalent to the syntax: fromuser – touser

remap_tablespace –  as above to be used when changing the target user space

Link to helpful article (import syntax a bit simpler):

http://orafaq.com/wiki/Datapump

Attention!!!

Depending on your version of the target ORACLE 11 server and licensing mode, there is a possibility of errors during import:

1. Error caused by enabling space saving features for empty data structures in the ORA engine configuration.

You should then:

– execute the command on the target ORACLE instance:

  • <SQL> ALTER SYSTEM SET DEFERRED_SEGMENT_CREATION=FALSE;

– retry import.

2. Error related to the lack of support for the above-mentioned database engine function

You should then:

– import by enforcing backward compatibility with the previous version of server import, for example:

  • <CMD> impdp system/pass Directory=asistkopia dumpfile=asist_kopia_export.dmp schemas=asist5 version=11.1 logfile=asist_kopia_import.log
How can I migrate data from Derby to Oracle?

To transfer a database from Derby to Oracle, follow the instructions below:

It is recommended to prepare a new PDB database for aSISt (asistPDB). If you have PDB database, you can use it. It is not necessary to create separate PDB to aSISt. Using the root database is not recommended.

To create asistPDB you can:

  • use sql:

<SQL> CREATE PLUGGABLE DATABASE asistpdb ADMIN USER asistdba identified by “asist” DEFAULT TABLESPACE USERS DATAFILE ‘D:\APP\ORACLE12\ORADATA\ASIST\ASIST\USERS01.DBF’ SIZE 1G AUTOEXTEND ON FILE_NAME_CONVERT=(‘D:\APP\ORACLE12\ORADATA\ORCL\PDBSEED\’,’D:\APP\ORACLE12\ORADATA\ASIST\ASIST\’);

<SQL> ALTER PLUGGABLE DATABASE asistpdb open read write;

<SQL> ALTER PLUGGABLE DATABASE asistpdb SAVE STATE;

Note: The path in the first SQL has to define the existing place and files.

  • use the instruction available on the Oracle website.

To create a new Oracle user can be used SQL:

<SQL> alter session set container = asistpdb;

<SQL> create user asist identified by asist default tablespace users temporary tablespace temp;

<SQL> grant connect,resource,create view to asist;

<SQL> GRANT UNLIMITED TABLESPACE TO asist;

SQL can be modified if you need to change the path or database name, user name.

Please connect with the new asist user. 

Next, it is required to prepare backup of Derby database.

If you have the backup, you can start the migration.

Please run derby_2_oracle_migrator.bat which is available in aSISt5 directory:

In the wizard it is required to fill:

User: asist     (migr in attached screenshots)

Password: asist      (migr in attached screenshots)

Address: jdbc:oracle:thin:@//localhost:1522/asistpdb      (format for Oracle 12, you have to fill the address for the new asist connection including the proper PDB database – orclpdb in my case)

If the user, password, and address are correct, please use the button “Next”.

Next step is summary:

Please use the button “Finish”.

You will see the information as below:

The migration process should take few minutes. Error messages should not be presented.

How to reset the Oracle database password (ORA-28001 error)

ORA-28001 error indicates the password has expired.

In order to reset the password, on the computer on which the Oracle database is located, run the command line start-> run-> cmd

And then perform:

  1. sqlplus  /nolog
  2. connect / as sysdba
  3. ALTER USER user_name IDENTIFIED BY new_password;

Please remember that after you reset your password, you must enter it in the window that appears when you start the aSISt application.

What does the “ORA-12519: TNS: no appropriate service handler found” error mean when trying to start the application?

In case of a database error „ORA-12519: TNS: no appropriate service handler found” when the next user cannot log in to the aSISt application, despite having the appropriate multi-user license, perform the following actions:

1. Verify the current database settings by following the steps below:

  • Log in through sqlplus as the sysdba aSISt database,
  • Perform the query: +

select current_utilization, max_utilization, limit_value from v$resource_limit where resource_name = ‚processes’;

If the current_utilization obtained is close to the set parameter of the “processes” database specified by the limit_value value from the above query, this may be the reason for the inability to connect another user to the aSISt application. One user log in does not create only one process / session based on Oracle. It involves launching other internal base processes running in the background, as well as database server processes whose operation is saved to trace_file files, so that in case of internal database errors,we have a stack of their origin, which makes it easier to diagnose the cause of problems.

2. Change the value of the processes parameter

Therefore, we suggest raising the parameter from the limit value to 120 for 5 users who log in to the aSISt application (also to the Oracle database at the same time).

This can be done with a command executed on a user with the sysdba role. To log in as this user:

  • Run the command line as an administrator
  • Enter the sqlplus command
  • In the username field enter / as sysdba
  • Run the command

ALTER SYSTEM SET processes = 120 SCOPE = SPFILE;

The session value coupled with the processes parameter will be determined automatically by the oracle server using a special algorithm.

3. Because the change is saved in spfile (server parameters file), the database must be restarted for the changes to take effect.

Restart can be done by log into sqlplus as sysdba (login method is presented above)

  • Log in as sysdba to the database
  • Save changes to aSISt and log out of the application
  • Close the database – shutdown immediate
  • Assemble and open the database – startup

4. If the parameter value is insufficient, you can increase its level again (point 2) and then restart it again (point 3).

How can you enable ARCHIVELOG mode for an Oracle database and define the FRA area settings?

To enable the ARCHIVELOG mode:

  • run the SQL command interpreter, eg. sqlplus.exe:

issue the command -> Start Menu -> Run ->  „sqlplus.exe /nolog”

  • using the „connect SYS/hasło as SYSDBA” command, connect the interpreter to the default instance of the Oracle database (in the Express Edition it is “XE”) as a full SYS user.
  • create a target directory for the FRA area and issue the command string:

SHUTDOWN IMMEDIATE
STARTUP MOUNT
ALTER DATABASE ARCHIVELOG;
ALTER SYSTEM SET DB_RECOVERY_FILE_DEST = ‚nazwa_partycji:katalog’;
ALTER SYSTEM SET DB_RECOVERY_FILE_DEST_SIZE = 15G;
ALTER DATABASE OPEN;
Exit

The database will be stopped and then started with the new settings.

What does the “IO Error: The Network Adapter could not establish the connection” error mean when trying to start the application?

„IO Error: The Network Adapter could not establish the connection”, 

it indicates that there is no network connection to the server.

In this case, you should:

  • check if there are correct entries of server address, port and instance name in the aSISt db.properites subdirectory.
  • using the telnet command check whether it is possible to establish connection from the client system shell, eg.: <CMD> telnet 192.108.0.131 1591.

You should see a flashing cursor (connection set up) or connection timeout if:

  • the port or service is blocked on the ORA server firewall,
  • there is no network communication to the server.

In such a situation, the client connections to the ORA server on port 1591 and to the ORA engine (eg.: C:\oracle\product\10.1.0\db_1\BIN\ORACLE.EXE) should be allowed accordingly.

Then retest via telnet or a network scanner, or troubleshoot packet routing.

How to add missing forms in the created report

If in the created report not all the required forms are available, then through the function:

“Report” -> “Report settings” -> “Forms”

you need to move the missing forms from the left to the right panel of the window.

Is there any easy way to print all completed forms?

The easiest way to print all completed forms is to use the “Print filled tables” function by selecting:

“Table” -> “Print filled tables”

If the displayed list has tables for which we would like to make changes in the print settings, then without leaving this function, you can do it by:

  • right-clicking on the selected table and
  • after entering the print preview, make the appropriate changes

The changes made to the print settings will be remembered by the system and taken into account when printing in the following months.

How to copy data from the previous month to the current report?

The function that allows copying data from another month is: “Load data from another report”.

To be able to copy data, you should:

  • open the table to which we want to copy the data,
  • select: “Table” -> “Load data from another report”,
  • indicate the month from which we want to copy the data,
  • confirm your choice.
How to execute the upgrade script for the Oracle database?

In order to execute the upgrade script for the Oracle database:

  1. save the oracle.sql file sent by aSISt support to the disk,
  2. from the command line run sqlplus (without switches),
  3. log in with the username and password used to connect to the database in the aSISt program,
  4. execute the script with @<script_path> e.g. @C:Oracleoracle.sql,
  5. save changes using commit
How to set not expiring password for ORACLE database for the profile to which the user belongs?

To disable the option to expire the password for the Oracle database to which the aSISt application connects, you should:

1. Run the command line start-> run-> cmd with administrator privileges and execute the commands:

  • sqlplus  /nolog
  • connect / as sysdba

2. Check the profile for the asist5 user using the command:

  • select profile from DBA_USERS where username = ‘asist5’;

The query returns the name of the profile to which the user belongs. Usually it is a profile called DEFAULT, otherwise you should change the name of this profile in the command indicated in point 3.

3. Set the password not to expire for the profile to which the user ‘asist5’ belongs using the command:

  • alter profile DEFAULT limit PASSWORD_LIFE_TIME unlimited;

To check if the password expire option has been disabled for user ‘asist5’, run the command:

at sqldeveloper:

  • select username, account_status, EXPIRY_DATE from dba_users where username=’asist5′;

If (null) appears in the ‘Expiry_Date’ column, it means that the password will not expire for the given user.

in sqlplus:

  • select username, account_status, nvl(expiry_date,’null’) from dba_users where username=’asist5′;

If (null) appears in the ‘Expiry_Date‘ column, it means that the password will not expire for the given user.

How to check what encoding does the installed Oracle database use?

The encoding of an Oracle instance can be checked by sending the appropriate queries:

  • from the level of aSISt application
  • after login to the Oracle database

I. To check the encoding of the installed Oracle database from aSISt application level, select:

ALT + A -> aSISt information -> button: ‘SQL Console’

At the top of the displayed window:

  • enter the query:

select * from NLS_DATABASE_PARAMETERS

where parameter=’NLS_CHARACTERSET

  • select the button:

as shown in the figure below:

II. To check the encoding after login to the Oracle database:

  • add the semicolon to the query given above, so that it has the form:

select * from NLS_DATABASE_PARAMETERS

where parameter=’NLS_CHARACTERSET’;

The encoding of the ORACLE database instance, correctly supported by aSISt, is: AL32UTF8.

How to check the ORACLE database version?

To check the ORACLE database version on which the aSISt application is running, you should:

  1. Run the command line as an administrator on the database server
  2. Enter sqlplus
  3. In the place where the user should be given, enter / as sysdba
  4. Enter the command: SQL*Plus: Release database_version

As a result, you will receive information about the Oracle database version.

How to repair a damaged Derby database?

Very often problems with the Derby base arise as a result of disk damage, or lack of free space. Please check your hard disk before repairing the database.

To repair the database, please:

  1. Start the recovery.bat file (it is located in the aSISt home directory),
  2. Answer YES to the question: “Do you want to perform the derby repair process?”,
  3. Indicate the last backup (for example: asist_backup_5.11_2015-01-15_11-30-32.zip). To repair the database, use a backup that was made from the same application installation.

After completing the process of repairing the database, an information message will appear that the repair of the database has been completed.

If the damage to the database is too big, then repairing the base is not possible.

Where can I check in what taxonomy the report has been prepared if the “Report settings” function is not active?

The “Report settings” function is active only for editing reports, i.e. for those having the status of “editing raw data” or “editing in reconciliation mode”.

For non-edited reports, information on the taxonomy prepared in the report can be obtained using the function, “Report details” selected in the “List of reports” mode, after:

  • highlighted in the list of the required report
  • selecting “Report” -> “Report details”
How to remove filters applied to “List of reports”?

To quickly remove all search filters that you have set, you must:

  • activate the filter function by choosing:

“View” -> “Show filter”

  • select the ‘X‘ icon next to the period filter

After completing these steps:

  • the screen will present a list of all reports in the aSISt database
  • defined and saved filters will still be visible and possible to use under the ‘Saved filters’ button
  • defined but unsaved filters will be no longer available

To what address should I send queries in case of problems with aSISt application?

All inquiries related to the aSISt application, please send to: support@asist-xbrl.eu

It can be done:

What to do to receive emails about new versions of aSISt?

To receive emails about the new versions of aSISt, you must register on the aSISt service page.

The correct registration process requires that you complete the following steps:

1. Access the Website: https://support.asist-xbrl.eu/en/

2. Find and select the “REGISTER” function (the function is available on the black bar in the page headline menu)

3. Choose the option:

  • aSISt_ENG

4. Give:

  • name and surname
  • email address to which information from the Website will be sent
  • name of the represented bank

5. Acceptance:

  • privacy policy of GPM Systemy sp z o.o. and regulations for the provision of electronic services
  • consent to the processing of personal data for marketing purposes and for sending commercial information by electronic means by GPM Systemy sp z o.o.
  • consent to the processing of personal data for the purposes of sending the form by GMP Systemy sp.z o.o.

6. Perform a mathematical operation and provide the correct result

7. Selecting the “NEXT” button that will send the account activation message to the previously provided email address

8. Opening the message from the “aSISt Team” and clicking on the activation link confirming registration at https://support.asist-xbrl.eu/en/

How to add new users to aSISt application?

From 5.0 version, all changes related to accounts of previously created users, and adding new users take place in the “Users and role” module tab, in the side tab “User Account Management”.

To add a new user, use the function:
“User” -> + Add

The following information is required here:

  • New user names,
  • Access passwords for the added users,
  • User (role) permissions – by moving the required role to the right window panel.

It is optional to enter other data in this function.

This function is only available to users with administrator privileges.

How can you log into the newly installed aSISt application?

After starting the aSISt application, the login panel is displayed, to which you should enter:

  • Login: admin
  • Password: admin

these are the default settings with system administrator privileges.

In the next step, add accounts for all users who are going to work in aSISt, so that each user can log in to the application through their own account.

What requirements should have a computer with the aSISt application installed?

The hardware requirements for the aSISt application are specified in the document: Specification of hardware requirements for: aSISt, tranSIS systems

What should I do if my aSISt application works too slow?

If your application works to slow, please:

  • compare aSISt requirements with parameters of your computer.

Requirements for aSISt application are available at: https://support.asist-xbrl.eu/sites/default/files/documentation/aSISt_tranSIS-_system_requirements.pdf,

Go to the Settings (ALT+A -> Settings), click on tab: LOCAL, and go to the tab:

  • Memory management and add more memory moving the slider further, but it is not advised to move it to the end of the scale (The amount of available memory depends on the amount of RAM available on your computer).

Please notice that the application needs more time when report is opened for the first time with a new taxonomy.

How I can delete report?

It is not possible to delete report in the aSISt application, but it is possible to make changes in settings defined during creating a report. In this case please choose “Report” in the menu, and next click on “Settings”. You will be able to:

  • add or delete forms from the report,
  • make changes in explicit and typed dimensions.

It is impossible to change:

  • report’s type,
  • report’s period, and
  • consolidation’s type. 
How to check the version of the aSISt application?

To check the version of your aSISt application, please run function “about aSISt”, selecting:

Alt-A  -> about aSISt

The application window also presents information about database version and database type (ORACLE or DERBY).

How can I enable blanked (greyed out) cells on the report’s table in the aSISt application?

From version 5.16 of aSISt application it is possible to activate explicit dimensions from cell’s level (right mouse button – “Enable Cell”).

If function  “Enable cell” is unavailable, it means that the cell is deactivated because of taxonomy and it is impossible to activate it.

What should I do to transfer the aSISt application with Derby database to a new computer?

To transfer the aSISt application from current computer to a new workstation, please:

1. Make a backup of derby database using function “Preparing backup” (ALT+A -> “Preparing backup”),

2. Download full version of aSISt from our website (https://support.asist-xbrl.eu/en/downloads),

3. Install aSISt application on the new computer using downloaded file,

4. From the old aSISt home directory please copy to the new aSISt home directory file:

  • aSISt.license,

and catalogue:

  • preferences (If you would like to have the same user’s settings on the new workstation just like you had on the old one).

5. Update the aSISt application to the current version using:

  • local update (using file/files downloaded from our website),
  • automatic update (If you have internet connection and proper address for update config file).

6. On the new computer upload file with backup which was created from the old database.

7. Go to the Settings (ALT+A -> Settings), click on tab: LOCAL, and next go to tab:

Memory management and add more memory moving the slider further, but it is not advised to move it to the end of the scale (The amount of available memory depends on the amount of RAM available on your computer).

8. On the old computer, rename the db.properties file [for example: db_old.properties] so that, even an accidental attempt to run the application on the old computer does not interfere with the current work of aSISta.

When do I have to update Oracle database additionally? How can I update Oracle database?

In case of the aSISt application update to the full version (when second value after point changes, for example for updates to versions: 5.15, 5.16, 5.17,…) it is necessary to additionally update the Oracle database.

To update Oracle database please:

  1. run update (local or from internet),
  2. during update, click on “OK”, when there will be a question about the update method: with or without the database

Update with the database:

  • it is necessary only once on one workstation
  • can be made only when
    • aSISt is running only on this particular workstation, and additionally:
    • no other workstations are subject to updates.

When updating next workstations the update is made only to the application.

If, during the update on the first workstation, you have omitted the database update and updated only the application, the database must be updated during the next workstation update.

If, during the update on all workstations, you have omitted the database update, then please contact aSISt support team with request about script for updating Oracle database, and next:

  • In CMD run sqlplus,
  • Log in using login and password for aSISt Oracle user,
  • Run script using: @<path_for_the_script> i.e. @C:Oracleoracle.sql,
  • Save changes using command: commit.
I am not sure if I downloaded update file from the aSISt website completely. How can I check it?

Since 5.16.2 version of the aSISt application the link to the file with checksums is available in the lower part of the update package.

To be sure that downloaded file is correct, please create checksums from the file and compare with checksums which are available on our site. 

What should I do to transfer the aSISt application with Oracle database to a new computer?

To transfer the aSISt application with Oracle database it is needed to move to a new server:

  • Oracle database (It can be made using Oracle tools (it is possible to use standard import and export tools)), and:
  • aSISt application

To move the aSISt application from an old workstation to the new, please:

1. Download the full aSISt version from our website (https://support.asist-xbrl.eu/en/downloads),

2. Install the aSISt application on the new workstation using downloaded file,

3. From the old aSISt home directory please copy to the new aSISt home directory files:

  • aSISt.license,
  • db.properties,

and catalogue:

  • preferences (If you would like to have the same user’s settings on the new workstation just like you had on the old one).

In the file db.properties there are information about: URL address to the Oracle database, user name and password for aSISt user. It is possible to make changes in the file if something is incorrect.

4. Update the aSISt application to the newest version (ALT+A -> Update).

There are two ways to update the aSISt application

  • local update (using file/files downloaded from our website), or
  • automatic update (If you have internet connection and proper address for update config file).

5. Go to the Settings (ALT+A -> Settings), click on tab LOCAL, and next go to the tab:

Memory management and add more memory moving the slider further, but it is not advised to move it to the end of the scale (The amount of available memory depends on the amount of RAM memory available on your computer).

Which files should I send to the aSISt support team in case of problems with application?

In case of any problems with the aSISt application, please attach the file with logs to the email addressed to: support@asist-xbrl.eu

To generate logs, please run the “About aSISt” function (ALT+A -> About aSISt) and in the new window click the “Dump debug data” button.

The “dump.zip” file doesn’t contain report data. It includes information about the operation of the application when problem occurred.

If you still can’t find solution, go ahead to contact with us

Report issue